Невозможно найти модуль 'uglifyjs-webpack-plugin', даже с версией 1.2.7

Jonas Arcangel спросил: 13 июня 2018 в 10:46 в: angular

Я обновил свой пакет.json, так что я использую uglifyjs-webpack-plugin 1.2.7.

Ошибка: не удается найти модуль 'uglifyjs-webpack-plugin'

Я получаю сообщение об ошибке при запуске следующей сборки.

ng build --prod && ng run ModuleIssue:server:production && webpack --progress --colors

У меня есть следующие зависимости и devDependencies в моем пакете. json.

  "dependencies": {
    "@angular/animations": "^5.2.0",
    "@angular/common": "^5.2.0",
    "@angular/compiler": "^5.2.0",
    "@angular/core": "^5.2.0",
    "@angular/forms": "^5.2.0",
    "@angular/http": "^5.2.0",
    "@angular/platform-browser": "^5.2.0",
    "@angular/platform-browser-dynamic": "^5.2.0",
    "@angular/platform-server": "^5.2.0",
    "@angular/router": "^5.2.0",
    "@ng-bootstrap/ng-bootstrap": "^1.1.2",
    "@nguniversal/module-map-ngfactory-loader": "^5.0.0-beta.5",
    "aspnet-prerendering": "^3.0.1",
    "bootstrap": "^4.0.0",
    "core-js": "^2.4.1",
    "rxjs": "^5.5.6",
    "webpack": "^4.15.1",
    "webpack-cli": "^3.0.8",
    "zone.js": "^0.8.19"
  },
  "devDependencies": {
    "@angular-devkit/build-angular": "^0.6.8",
    "@angular/cli": "^6.0.8",
    "@angular/compiler-cli": "^5.2.0",
    "@angular/language-service": "^5.2.0",
    "@types/jasmine": "~2.8.3",
    "@types/jasminewd2": "~2.0.2",
    "@types/node": "~6.0.60",
    "codelyzer": "^4.0.1",
    "jasmine-core": "~2.8.0",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~2.0.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "^1.2.1",
    "karma-jasmine": "~1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.1.2",
    "ts-node": "~4.1.0",
    "tslint": "~5.9.1",
    "typescript": "~2.5.3",
    "uglifyjs-webpack-plugin": "^1.2.7"
  }

Полный пакет package.json и angular.json можно найти по адресу https:// github.com/jonasarcangel/ModuleIssue/tree/master/ClientApp

Я не знаю, какой пакет / версия вызывает эту проблему.


1 ответ

Есть решение
Moshe ответил: 15 июня 2018 в 02:08

Мне кажется, что вы пытаетесь добавить рендеринг на стороне сервера, пожалуйста, следуйте этому руководству: angular.io/guide/universal

Дополнительное видео по вопросу: Невозможно найти модуль 'uglifyjs-webpack-plugin', даже с версией 1.2.7

How to Install Webpack, Setup a Config File, and Minify JavaScript - Ep. 2