Ошибка импорта tenorflow-gpu в ubuntu18.04

yanhei Wu спросил: 03 ноября 2018 в 08:12 в: python

Я получаю сообщение об ошибке при импорте тензорного потока.

Технические характеристики моего компьютера:

ОС: ubuntu 18.04

Nvidia RTX 2080 Ti 2

Nvidia driver-415

CUDA : 10.0

cuDNN : 7.3.0tensorflow : 1.11.0

import tensorflow

Ошибка :

Traceback (последний вызов был последним): файл"/usr/local/lib/python3.6/dist-packages/tensorflow/python/pywrap_tensorflow.py", строка 58, от tenorflow .python.pywrap_tensorflow_internal import File"/usr/local/lib/python3.6/dist-packages/tensorflow/python/pywrap_tensorflow_internal.py",line 28, файл in_pywrap_tensorflow_internal = swig_import_helper ()" / usr / local / lib / .6 / dist-packages / tenorflow / python / pywrap_tensorflow_internal.py", строка 24, в файле swig_import_helper_mod = imp.load_module ('_ pywrap_tensorflow_internal', fp, путь, описание) Файл" /usr/lib/python3.6/imp.py", строка 243, в load_modulereturn load_dynamic (имя, имя файла, файл) Файл" /usr/lib/python3.6/imp.py", строка 343, в load_dynamicreturn _load (spec) I mportError: libcublas.so.9.0: невозможно открыть файл общего объекта: такого файла или каталога нет:

Во время обработки вышеуказанного исключения произошло другое исключение:

Traceback (последний вызов был последним ): Файл"", строка 1, inFile"/usr/local/lib/python3.6/dist-packages/tensorflow/init.py", line22, infens tenorflow.python import pywrap_tensorflow # pylint : disable = unused-import File"/usr/local/lib/python3.6/dist-packages/tensorflow/python/init.py", строка 49, информация из файла tenorflow.python import pywrap_tensorflow File" /usr/local/lib/python3.6/dist-packages/tensorflow/python/pywrap_tensorflow.py",line 74, inraise ImportError (msg) ImportError: трассировка (последний вызов был последним): файл"/ usr / local / lib /python3.6/dist-packages/tensorflow/python/pywrap_tensorflow.py",line 58, infens tenorflow.python.pywrap_tensorflow_internal import File"/usr/local/lib/python3.6/dist-packages/tensorflow/python/ pywrap_tensorflow_internal.py", строка 28, in_pywrap_tensorflow_internal = swig_import_ Файл helper ()"/usr/local/lib/python3.6/dist-packages/tensorflow/python/pywrap_tensorflow_internal.py",line 24, в файле swig_import_helper_mod = imp.load_module (файл '_ pywrap_tensorflow_internal', fp, pathname, description) "/usr/lib/python3.6/imp.py", строка 243, в файле load_modulereturn load_dynamic (имя, имя файла, файл) Файл "/usr/lib/python3.6/imp.py", строка 343, в файле load_dynamicreturn _load (spec) ImportError: libcublas.so.9.0: невозможно открыть общий объектный файл: нет такого файла или каталога

Не удалось загрузить собственную среду выполнения TensorFlow.

Seehttps:// www. tenorflow.org/install/install_sources#common_installation_problems

по некоторым распространенным причинам и решениям. При запросе помощи включите весь стек выше этой ошибки.

Я уже пытался использовать Ubuntu 16.04, но графический процессор не поддерживал. Установка CUDA9.0 & CUDA9.2 тоже не поддерживается.

как я могу использовать tenorflow-gpu?

Я уже проложил путь к приложению в ~ / .bashrc

export PATH=/usr/local/cuda-10.0/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
export CUDA_HOME=/usr/local/cuda-10.0
export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64
export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64$LD_LIBRARY_PATH

0 ответов