Реализация 'com.android.support:appcompat-v7:28.0.0'

Black Box спросил: 07 октября 2018 в 01:30 в: android

Я делаю первые шаги в программировании приложений.

Я искал другие темы, связанные с этим вопросом, и пробовал все решения, но все же это сводило меня с ума:

building в Android Studio я не могу сделать это из-за этой ошибки о

implementation 'com.android.support:appcompat-v7:28.0.0' :

все библиотеки com.android.support должны использовать одну и ту же спецификацию версии (смешивание версии могут привести к сбоям во время выполнения).

Найденные версии 28.0.0, 26.1.0.

Примеры включают в себя

и

com.android.support:animated-vector-drawable:28.0.0

Существуют некоторые комбинации библиотек или инструментов и библиотек, которые несовместимы или может привести к ошибкам. Одной из таких несовместимостей является компиляция с версией библиотек поддержки Android, которая не является последней версией (или, в частности, версией ниже, чем ваша targetSdkVersion).

если я проигнорирую ее с помощью команды"noinspection", то apk не работает на моем телефоне. Я попытался добавить некоторые зависимости, как в примере строки, но это не работает в данный момент, который я показываю выше, потому что если добавить "support version 4: 26.1.0", это говорит мне, что это не самая последняя версия, и если я обновлю его, написав 7: 28.0.0 это тоже не работает.

Может кто-нибудь помочь мне, пожалуйста? Спасибо за ваше время!

Редактировать: это мой build.gradlehttps://www.dropbox .com / sh / 1vjmrh196bdy5gn / AADW-DG1YB10s-Csw_UrZtuYa? dl = 0

Я применил предложения ниже (СПАСИБО !!), и ошибка больше не отображается, НО мое приложение по-прежнему падает как в эмуляторе, так и в мое устройство (галактика а6 +).


0 ответов