Обновите промежуточные зависимости npm с помощью package-lock.json

rink.attendant.6 спросил: 13 октября 2017 в 06:33 в: node.js

Как правильно обновить промежуточную зависимость с помощью npm при наличии файла package-lock.json?

Например:

$ npm outdated --depth=1 eslint
Package  Current  Wanted  Latest  Location
eslint     4.9.0  4.10.0  4.10.0  MyApplication1 > grunt-eslint

Package-lock.json выполняет свою работу, сохраняя eslint (промежуточная зависимость, в данном случае для grunt-eslint) на уровне 4.9.0. Как мне обновить систему до eslint@4.10?

Я пробовал следующие команды, но npm ничего не делает:

npm update grunt-eslint --dev --depth 1
npm update eslint --dev

Это работает, если я добавляю eslint как зависимость верхнего уровня, но я не думаю, что это правильный способ сделать это.


0 ответов