Ошибка: нет поставщика для магазина! в @ngrx 4.x

Anton Poznyakovskiy спросил: 13 октября 2017 в 06:50 в: angular

При переносе моего проекта из @ngrx 2.x в 4.1.0 я обнаружил сообщение об ошибке

NullInjectorError: Нет поставщика для Store!

Магазин был импортирован, как показано в документации:

import { StoreModule as NgRxStoreModule } from '@ngrx/store';@NgModule({
  imports: [
    NgRxStoreModule.forRoot(reducerMap, {
      initialState: initial
    }),
    StoreRouterConnectingModule,
    EffectsModule.forRoot(effects)
  ],
  providers: [AppActions]
})
export class StoreModule {}

0 ответов