Невозможно собрать проект студии Android, не может получить доступ к файлу класса zzbcc для com.google.android.gms.internal.zzbcc не найден

geniushkg спросил: 26 ноября 2017 в 05:27 в: android

Все шло хорошо, но недавно в будние дни, теперь проект не строится,

не может получить доступ. Ошибка файла класса zzbcc связана с картами. Возможно, это происходит при использовании метода Добавить маркер для кода карты Google i. Использовал в моем проекте

Это мой текущий файл сборки Gradle

buildscript {
repositories {
    maven { url 'https://maven.fabric.io/public' }
}dependencies {
    classpath 'io.fabric.tools:gradle:1.+'
}}dependencies {/*For Facebook Sign in*/
compile files('libs/YouTubeAndroidPlayerApi.jar')
//fort lib
compile project(':FORTSDKv1.4')
compile project(':likebutton')
compile project(':infiniteviewpager')
compile 'com.android.support:support-v4:27.0.0'
compile 'com.android.support:appcompat-v7:27.0.0'
compile 'com.intuit.sdp:sdp-android:1.0.4'
compile 'com.squareup.picasso:picasso:2.5.2'
compile 'com.android.support:design:27.0.0'
compile 'com.android.support:recyclerview-v7:27.0.0'
compile 'com.android.support:cardview-v7:27.0.0'
compile 'com.android.support:palette-v7:27.0.0'
compile 'com.github.clans:fab:1.6.2'
compile 'de.hdodenhof:circleimageview:2.1.0'
compile 'com.mcxiaoke.volley:library-aar:1.0.0'
compile 'uk.co.chrisjenx:calligraphy:2.1.0'
compile 'com.squareup.okhttp3:okhttp:3.5.0'
compile 'com.github.florent37:arclayout:1.0.1'
compile 'com.flaviofaria:kenburnsview:1.0.7'
compile 'com.jakewharton:butterknife:8.4.0'
compile 'com.squareup.retrofit2:retrofit:2.1.0'
compile 'com.squareup.retrofit2:converter-gson:2.1.0'
compile 'com.github.bumptech.glide:glide:3.7.0'
compile 'com.squareup.okhttp3:logging-interceptor:3.4.1'
//    compile 'com.google.android.gms:play-services-auth:9.2.1'
compile 'com.facebook.android:facebook-android-sdk:4.0.1'
//    compile 'com.google.android.gms:play-services-appindexing:9.2.1'
compile 'com.yayandroid:ParallaxRecyclerView:1.1'
compile 'com.github.scottyab:showhidepasswordedittext:0.8'
compile 'com.txusballesteros:bubbles:1.2.1'
compile 'com.victor:lib:1.0.1'
compile 'com.shamanland:fonticon:0.1.8'
compile 'com.google.guava:guava:19.0'
compile 'org.bouncycastle:bcprov-jdk16:1.46'
compile 'commons-codec:commons-codec:1.10'
compile 'com.vinaygaba:creditcardview:1.0.3'
//    compile 'com.google.android.gms:play-services-maps:9.2.1'
compile 'com.android.support:multidex:1.0.1'
compile 'com.github.damson:Bright:v1.1.0-release'
//    compile 'com.google.android.gms:play-services:9.2.1'
compile 'com.yalantis:ucrop:2.2.0'
compile 'com.android.support.constraint:constraint-layout:1.0.2'
compile 'com.wang.avi:library:2.1.3'
testCompile 'junit:junit:4.12'
annotationProcessor 'com.jakewharton:butterknife-compiler:8.4.0'
compile('com.crashlytics.sdk.android:crashlytics:2.6.8@aar') {
    transitive = true;
}
// OneSignal SDK
compile 'com.onesignal:OneSignal:[3.6.1,3.99.99)'
compile 'com.google.android.gms:play-services:11.2.2'
compile 'com.google.android.gms:play-services-auth:11.2.2'
compile 'com.google.android.gms:play-services-maps:11.2.2'
compile 'com.google.firebase:firebase-appindexing:11.2.2'
compile 'com.google.firebase:firebase-messaging:11.2.2'
compile 'com.google.code.gson:gson:2.8.2'
//compile 'com.adjust.sdk:adjust-android-criteo:4.2.3'
compile 'com.adjust.sdk:adjust-android:4.11.4'
compile 'com.google.android.gms:play-services-analytics:11.2.2'
}
apply plugin: 'com.google.gms.google-services'

Очистить сборки успешно, но не могу запустить приложение или сгенерировать подписанный apk, я видел несколько одинаковых вопросы, которые они указывают на проблему с зависимостями, но в этом случае службы Firebase и Google Play оба одинаковы.


Решено Делая зависимости Firebase и службы Google Play одинаковыми, а также используя последние стабильная версия для обоих

0 ответов