Смутно о том, чтобы запустить Scala в IntelliJ? Ошибки импорта

CapnShanty спросил: 03 февраля 2018 в 12:34 в: scala

Я пытаюсь запустить простую программу scala в IntelliJ.

My build.sbt выглядит так:

name := "UseThis"version := "0.1"scalaVersion := "2.12.4"libraryDependencies += "org.apache.spark" %% "spark-core" % "1.2.0"

И мой код импорта выглядит так: this:

package WorkWork.FriendsByAgeimport com.sun.glass.ui.Window.Level
import com.sun.istack.internal.logging.Logger
import org.apache.spark._
import org.apache.spark.SparkContext._
import org.apache.log4j._

Я не понимаю, почему импорт завершается неудачно. Он сообщает мне, что зависимость не загружалась или не была найдена, но я поместил строку в build.sbt, как требуется. Есть ли еще один шаг, который мне нужно сделать? Я установил искру. Это примечание к версии в конце строки сборки? Я даже не знаю, как проверить, какая у меня версия искры. Я пытаюсь научить себя Scala (а не noob, хотя, я знаю Python, R, различные варианты SQL, C #), но мое слово даже настраивает его почти невозможно, и, видимо, заставить его даже бежать тоже. Любые идеи?

0 ответов